June 24, 2018, 12:31:59 AM

Author Topic: Pics of Muldoonmans gen  (Read 5303 times)

Offline wal1809

  • Hero Member
  • *****
  • Posts: 1374
Pics of Muldoonmans gen
« on: September 11, 2011, 07:04:35 PM »
Muldoon sent these to me and so I am going to post them for him.  He needs help with an overheating genset. 




1984 Silver Eagle Model 10 6V92 Allison auto tranny
www.snakebreaker.com

Offline wal1809

  • Hero Member
  • *****
  • Posts: 1374
Re: Pics of Muldoonmans gen
« Reply #1 on: September 11, 2011, 07:11:06 PM »
Muldoon I will start with the first question.  Has it always overheated and if not what changed other than Texas has been a miserable burning inferno for months.  Also we are close enough where we should meet one day for supper or coffee.  Schoebel's is a block north of I-10 on hwy71 in Columbus, Texas.  They have a buffet that will send you into a diabetic coma.  The last person I met there was a fella named Doc, an animal vet.  I met him on the internet as he was buying a rifle from me.  We decided to sit down for a meal and the next thing you know we spawned a business relationship and definately a lifelong friendship.  You just never know.
1984 Silver Eagle Model 10 6V92 Allison auto tranny
www.snakebreaker.com

Offline Lin

  • Hero Member
  • *****
  • Posts: 5249
  • 1965 MC-5a
Re: Pics of Muldoonmans gen
« Reply #2 on: September 11, 2011, 07:32:19 PM »
It looks great in the picture, but what's needed is the details of the cooling system.
You don't have to believe everything you think.

Offline jackhartjr

  • Hero Member
  • *****
  • Posts: 1347
  • Beauty is in the eye of the beholder!
Re: Pics of Muldoonmans gen
« Reply #3 on: September 11, 2011, 07:41:56 PM »
I don't know much about these...yet, however my first question was this, "How does it breathe!"
Jack
Jack Hart, CDS
1956 GMC PD-4501 #945 (The Mighty SCENICRUISER!)
8V71 Detroit
4 speed Spicer Trannsmission
Hickory, NC, (Where a call to God is a local call!)

Offline muldoonman

  • 1991 Prevost 8V92TA
  • Hero Member
  • *****
  • Posts: 904
  • 1991 Prevost 8V92TA
Re: Pics of Muldoonmans gen
« Reply #4 on: September 12, 2011, 08:19:24 AM »
Wayne, I just bought the bus a couple months ago. I've only tried to use genset a couple times and it shut down both times after running a couple of hours, maybe less. Genset only had 38 hours when i bought the bus. Now about 50 or so.The prevost bus 56,000 miles. Stored forever. I just picked it up from Texas Custom Coaches a week or 2 ago after a total check out and revamp. They had it on shore power and didn't run gen long enough to experience shutdown. The air intake is that hose in middle picture that goes out the side. There are no holes in compartment other than slide for electric cable out bottom. Doesn't seem like enough air intake for me. I'll hollar toward the end of week and see if we can meet up so you can take a look.Thanks for all the help, guys.

glen

Offline eddiepotts

  • Sr. Member
  • ****
  • Posts: 446
Re: Pics of Muldoonmans gen
« Reply #5 on: September 12, 2011, 08:50:20 AM »
One thing you might want to look for is an exhaust leak and it shutting down on lack of clean air and not heat. this may be why it will run for a few hours and not run strait up to high temp. I had a waverunner do this to me. Once I pulled the seat it would start right back up. The leak was so small I was not seeing it at first. when I fixed it ran all day no problems. Use a 1x2 going across the top of the bay door holding it open to see if it lets more fresh air in. Also try installing a thermometer in the bay by the intake and make sure your not sucking in hot air raising the cylinder temp. Cooler intake air cooler it will run.
« Last Edit: September 12, 2011, 08:53:07 AM by eddiepotts »

Offline Lin

  • Hero Member
  • *****
  • Posts: 5249
  • 1965 MC-5a
Re: Pics of Muldoonmans gen
« Reply #6 on: September 12, 2011, 10:26:32 AM »
Somehow, I can't see the air intake clearly.  Is it that thing that looks like it might a a screen going to the next compartment where the cable is?  Where is the radiator, and what condition is that in? 
You don't have to believe everything you think.

Offline wal1809

  • Hero Member
  • *****
  • Posts: 1374
Re: Pics of Muldoonmans gen
« Reply #7 on: September 12, 2011, 10:40:03 AM »
I am thinkin in the same lines as Lin.  We need to know how much air it has coming in and out.  We also need to know what kind of fan is on there.  They might have replaced the fan recently.  If it does not ram air through the radiator your shooting yourself in the foot.  It could be somehting as simple as the rubber seal on the outside of the radiator has been removed ect.  My guess is the fan is not strong enough for this Texas heat wave.  Luvrbus set me straight on the fans.  Mine took a 9 amp squirrel cage blower and ended that BS right off the bat.
« Last Edit: September 12, 2011, 10:42:57 AM by wal1809 »
1984 Silver Eagle Model 10 6V92 Allison auto tranny
www.snakebreaker.com

Offline gus

  • Hero Member
  • *****
  • Posts: 3624
Re: Pics of Muldoonmans gen
« Reply #8 on: September 12, 2011, 02:06:16 PM »
It is really hard to tell from the pics but it appears the air intake hose is to the engine air intake so it won't provide any cooling to the compartment. 

For cooling there has to be a cool air intake, preferably at the bottom, and a hot air outlet, preferably at the top.

My cooling air outlet is at the bottom (I really don't have much choice) but since I'm installing a 326 CFM. 0.95 amp squirrel cage blower that takes in bottom cooling air ahead of the exhaust it should work fine.

The sizes of a couple of blowers posted here amaze me, they are truly large enough to lift the bus!!
PD4107-152
PD4104-1274
Ash Flat, AR

Offline wal1809

  • Hero Member
  • *****
  • Posts: 1374
Re: Pics of Muldoonmans gen
« Reply #9 on: September 12, 2011, 02:08:07 PM »
It is really hard to tell from the pics but it appears the air intake hose is to the engine air intake so it won't provide any cooling to the compartment. 

For cooling there has to be a cool air intake, preferably at the bottom, and a hot air outlet, preferably at the top.

My cooling air outlet is at the bottom (I really don't have much choice) but since I'm installing a 326 CFM. 0.95 amp squirrel cage blower that takes in bottom cooling air ahead of the exhaust it should work fine.

The sizes of a couple of blowers posted here amaze me, they are truly large enough to lift the bus!!

Oh you mean like this one
1984 Silver Eagle Model 10 6V92 Allison auto tranny
www.snakebreaker.com

Offline muldoonman

  • 1991 Prevost 8V92TA
  • Hero Member
  • *****
  • Posts: 904
  • 1991 Prevost 8V92TA
Re: Pics of Muldoonmans gen
« Reply #10 on: September 13, 2011, 04:32:17 AM »
I'll try to get other pics on backside of gen set. It's in a totally inclosed insulated box with radiator to the right inclosed behind power cord. I will pull wall out as soon as I have time and take a look at radiator and blower. Will keep you posted.

Schobels, ah yes, I've eaten there many times over the years.

Thanks,
glen s.

Offline blank

  • Hero Member
  • *****
  • Posts: 1929
Re: Pics of Muldoonmans gen
« Reply #11 on: September 13, 2011, 06:10:55 AM »
  Not only does the engine need cooling (radiator), but so does the generator head itself. Most are rated at 40C. Dont know if that would shut it down though. Agree elsewhere, you need to put some thermometers in there so you have some baseline to work from. Just saying its shutting down isnt going to tell anything. 

Offline muldoonman

  • 1991 Prevost 8V92TA
  • Hero Member
  • *****
  • Posts: 904
  • 1991 Prevost 8V92TA
Re: Pics of Muldoonmans gen
« Reply #12 on: September 13, 2011, 06:46:15 AM »
Gotcha.Yeah, That puppy doesn't have any fresh air coming in to generator, not even a vent.

 Wayne, I'll hollar and maybe the wife and I can meet you all at Schobels on a weekend and you can see the bus and the problem first hand.

Offline eddiepotts

  • Sr. Member
  • ****
  • Posts: 446
Re: Pics of Muldoonmans gen
« Reply #13 on: September 13, 2011, 06:46:51 AM »
Does it shut down like you turned the switch off or does it choke down like you are running out of fuel?

Offline luvrbus

  • Hero Member
  • *****
  • Posts: 19427
Re: Pics of Muldoonmans gen
« Reply #14 on: September 13, 2011, 06:52:16 AM »
You need to look else where for the problem venting is not the problem at a 195 degrees you are ok it is venting,those units do fine in a box.
I notice it has a new shutdown on the engine those need to have the right adjustment you don't install one and call it good,check the sensors and the control board


good luck
Life is short drink the good wine first