June 24, 2018, 10:07:28 PM

Author Topic: Another brake question?  (Read 2235 times)

Offline jjrbus

  • Hero Member
  • *****
  • Posts: 2314
  • MCI5C/N Ft Myers FL
Another brake question?
« on: October 14, 2006, 02:38:35 PM »
 I've moved from Manatee springs to Chads place in Old Town. He has not done much with his bus and become a lurker.  Anyway he has the same bus as I do, (almost) mine is a 79 MCI5C 6/slushbox. His is a 1980 MCI5C that was a standard 8V71 converted to auto.
 After my experience, my topic of conversation was brakes. He took mine for a ride and noticed that the parking brake will release without a full application of the foot brake. He showed me the instructions on the switch panel on his bus, it says that after releaseing the parking brake a full application of the foot brake must be made to release the parking brake.
 Is my break right or do I have a problem?  Also my parking brake light does not always go out immediately when I relese the brake, is that a problem?
 Now I have to go check my clunk.
Remember, even at a Mensa convention someone is the dumbest person in the room!

http://photobucket.com/buspictures

http://photobucket.com/buspictures

Offline JackConrad

  • Orange Blossom Special II
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4448
  • 73' MC-8 8V71/HT740 Southwest Florida
Re: Another brake question?
« Reply #1 on: October 14, 2006, 04:59:41 PM »
Jim,
   Glad to see ya'll made it to Chad & Martha's.  Looking at the Buffalo weather, looks like you left just in time.  Check the adjustment on you slack adjusters. Maybe one of the adjusters was not "locked" by the spring loaded collar.  Jack
PS: tell our daughter Mom & Dad said Hi!
Growing Older Is Mandatory, Growing Up Is Optional
Arcadia, Florida, When we are home
http://s682.photobucket.com/albums/vv186/OBS-JC/

Offline Stan

  • Hero Member
  • *****
  • Posts: 973
Re: Another brake question?
« Reply #2 on: October 14, 2006, 06:08:51 PM »
On three different MCI buses I found that the park brake frequently would release when the Push-Pull valve was pushed in, if done immediately after applying the park brake.  As soon as there was any loss of air pressure in the system, this did not happen.  Somewhere I read that this was normal. Maybe RJ or Buswarrior has an answer.

Offline sommersed

  • Newbie
  • *
  • Posts: 48
Re: Another brake question?
« Reply #3 on: October 15, 2006, 08:20:03 AM »
In my 5A, it has to leak down 20 lbs (I think) before the brakes set.  If you do not engage the brake pedal during that time, which will also set the brakes, you can use the feature to get rolling on a hill, or taking off with having to apply brakes first.

Procedure is roll to a stop and set parking brake without applying pedal nor applying during stop.  When it's time to get rolling give it a LITTLE throttle, ease the clutch out till you feell it start to engage and at that time push in the knob for the parking brake. 

I have only used this feature one time, when I was forced to stop on a hill because of constrution. 

If done right you will not slip a properly adjusted clutch.

Ed
« Last Edit: October 15, 2006, 08:22:58 AM by sommersed »

Offline buswarrior

  • Hero Member
  • *****
  • Posts: 4572
  • '75 MC8 8V71 HT740
Re: Another brake question?
« Reply #4 on: October 18, 2006, 06:55:14 PM »
Hello.

Stan has it right. Unless there is a drop in pressure in the parking tank, which is blind to the dahboard gauge, so you don't know if it has dropped or not, the DD3 parking brake will release with the parking control only, no service brake application necessary.

The parking brake dash indicator may be a little slow as the pressure builds inside the pressure switch. As long as it goes out eventually, no worries.

Ed, RJ has an article over on BNO, when the articles of interest are restored, about dead pedal clutch use. You really don't want to be feeding throttle in while letting up the clutch. You can use your other foot to hold the brake on a hill.

happy coaching!
buswarrior
Frozen North, Greater Toronto Area