June 23, 2018, 08:27:47 AM

Author Topic: PD 4106 alternator not charging  (Read 4769 times)

Offline agetme

  • Newbie
  • *
  • Posts: 17
PD 4106 alternator not charging
« on: July 14, 2013, 04:29:25 AM »
Hello everyone, I have 1964 PD 4106 8v71.
Just recently started her after winter. All goes well save the alt charging.
Checked batt voltage and it is not showing a charge. Tried putting load on
system but still nothing.
Is this system air actuated or what? Sensing relay? I have ordered a new regular
as I need a spare anyway.
Any help would be great. I have a maintenance manual but do not have in with me at this time.
Away at work for next 10 days. Just trying to get some ideas to try when I get home.

thanks much in advance ;D
Tom Hamilton

Offline Utahclaimjumper

  • Hero Member
  • *****
  • Posts: 1261
Re: PD 4106 alternator not charging
« Reply #1 on: July 14, 2013, 12:55:25 PM »
 After starting, bring the RPM up to 1800 or so for a few seconds, these old regulators get tired after so many years and need a kick in the pants.>>>Dan
Utclmjmpr 
 EX 4106 (presently SOB)
Cedar City, Ut.
 72 VW Baja towed

Offline Tim Bookmiller

  • G.M. 4106 #pd1825
  • Jr. Member
  • **
  • Posts: 54
Re: PD 4106 alternator not charging
« Reply #2 on: July 15, 2013, 02:10:45 AM »
Make sure the "starter/gen" relay is working properly. With switch in on position the gen light will be on -after starting -rev engine some which pulls in contact on relay - and the charge will begin --which is how GM keeps you from engageing starter when engine is running and charging

Offline Barn Owl

  • Roanoke, VA
  • Hero Member
  • *****
  • Posts: 2080
  • PD4106-1063 "Wheezy Bus"
Re: PD 4106 alternator not charging
« Reply #3 on: July 16, 2013, 01:24:17 AM »
If you started it from the rear, make sure you switch the toggle back to run.
L. Christley - W3EYE Amateur Extra
Blue Ridge Mountains, S.W. Virginia
It’s the education gained, and the ability to apply, and share, what we learn.
Have fun, be great, that way you have Great Fun!

Offline luvrbus

  • Hero Member
  • *****
  • Posts: 19420
Re: PD 4106 alternator not charging
« Reply #4 on: July 16, 2013, 01:51:28 AM »
A simple test is stand by the alternator have someone turn the master run switch on if you don't hear the alternator engage then you have a bad charging relay and on a 12 volt system those are 6 volt relay not 12 volt so if you replaced the relay with a 12 volt relay there will be no charge don't ask how I know that  ::)
Life is short drink the good wine first

Offline eagle19952

  • Hero Member
  • *****
  • Posts: 3716
Re: PD 4106 alternator not charging
« Reply #5 on: July 16, 2013, 03:36:09 AM »
Being one who does not explain well, I have found these that MAY or may not help...I think they might. JUst keep in mind that all alternators don't have the hook-ups all in the same place...go only as far as you are comfortable....

[urlhttp://alternatorparts.com/understanding_alternators.htm][/url]

When done with the above.. go here...the simplest tests are checking for magnetic field....

http://www.bronek.org/sailing/zamindar/resources/Alternator-regulator%20troubleshooting.pdf

Here you will find the following and more.
Good Luck... :)

Alternator /Regulator Field Tests
Test A - The alternator and regulator can be tested for function by determining if a magnetic field exists at the alternator’s pulley
shaft or rear bearing. To test:
1. With the ignition in the OFF position, place the head of a steel screwdriver near the nut on the pulley shaft or near the
rear bearing of the alternator. There should be no evidence of a magnetic field pulling the screwdriver toward the alternator.
2. Engage the ignition, without starting the engine, to activate the voltage regulator. If an oil pressure switch is used, a
jumper across the switch will activate the regulator.
3. After allowing time for the regulator’s start-up delay, place the head of a steel screwdriver near the nut on the pulley shaft
or near the rear bearing of the alternator. There should be evidence of a magnetic field pulling the screwdriver toward the
alternator. If a magnetic field is present, the voltage regulator, alternator brushes and rotor are likely to be working properly.
If the system is not charging, remove the alternator and have it inspected by a qualified alternator shop.

Donald PH
1978 Model 05 Eagle w/Torsilastic Suspension,8V71 N, DD, Allison on 24.5's 12kw Kubota.

Offline TomC

  • Hero Member
  • *****
  • Posts: 8642
Re: PD 4106 alternator not charging
« Reply #6 on: July 16, 2013, 05:02:46 AM »
When I exchanged my 50DN for a rebuilt unit, I also changed the regulator. Went from the big black box transistorized to a digital regulator about the size of a pack of cigarettes.  Good Luck, TomC
Tom & Donna Christman. '77 AMGeneral 10240B; 8V-71TATAIC V730.

Offline agetme

  • Newbie
  • *
  • Posts: 17
Re: PD 4106 alternator not charging
« Reply #7 on: July 16, 2013, 09:03:33 AM »
Thanks for all the input. I guess that charging relay might be in the passenger side electrical panel near the rear of the bus?
Tom Hamilton

Offline baker4106

  • Full Member
  • ***
  • Posts: 164
Re: PD 4106 alternator not charging
« Reply #8 on: July 16, 2013, 11:24:19 PM »
On my 1961 4106 if the charging relay on the drivers side near the batteries does not pull in, it won't charge.

Offline gus

  • Hero Member
  • *****
  • Posts: 3624
Re: PD 4106 alternator not charging
« Reply #9 on: July 17, 2013, 09:21:46 PM »
Tomc,

Where did you get that reg and what did it cost?
PD4107-152
PD4104-1274
Ash Flat, AR

Offline agetme

  • Newbie
  • *
  • Posts: 17
Re: PD 4106 alternator not charging
« Reply #10 on: July 18, 2013, 03:44:38 AM »
Got the reg on ebay.

seller: autoelectricpart09
Tom Hamilton

Offline gus

  • Hero Member
  • *****
  • Posts: 3624
Re: PD 4106 alternator not charging
« Reply #11 on: July 19, 2013, 09:00:15 PM »
Thanks!
PD4107-152
PD4104-1274
Ash Flat, AR

Offline agetme

  • Newbie
  • *
  • Posts: 17
Re: PD 4106 alternator not charging
« Reply #12 on: August 01, 2013, 07:04:38 PM »
Found bad charging relay in rear electrical compartment. Plain 12v solenoid was bad, it was passing only 2.8v thru out of 12.8v.
Most likely corrosion on the inside dropping the voltage. Replaced the relay instant charging.

Thanks for all the info.

Tom H
Tom Hamilton

Offline gus

  • Hero Member
  • *****
  • Posts: 3624
Re: PD 4106 alternator not charging
« Reply #13 on: August 02, 2013, 04:44:17 AM »
TomC,

What is the P/N, all I can find is the old monster type?
PD4107-152
PD4104-1274
Ash Flat, AR

Offline agetme

  • Newbie
  • *
  • Posts: 17
Re: PD 4106 alternator not charging
« Reply #14 on: August 04, 2013, 10:37:34 PM »
ALTERNATOR Regulator Delco 19020403,19020402, 10457698

This was the listed one on ebay.


Tom Hamilton